Ender 3 Max with an SKR Mini E3 V2.0, a BLTouch, filament sensor firmware?

Yes, these options are already available in the Firmware Builder to allow that to be built.

However as mentioned, use the Ender 3 preset and change the bed size to suit the Ender 3 Max.

I don’t see an SKR option, only 4.2.2 & 4.2.7?

As mentioned, use the Ender 3 preset and adjust your bed size / build area to suit. You should be able to select the correct filament runout sensor options as well.

My apologies, you’re right. I’ll try that one.
The big problem is that when I do set the BLTouch for Z homing, as the Z gantry is coming down, I push the BLTouch pin and it sucks in but the gantry continues to drop until it hits the Z stop limit. It’s almost like the BLtouch is powered up but the firmware isn’t looking for that input, but still using the Z endstop switch.
Here’s settings I’m using:

If that’s still the case, I would check the black/white part of the cable on the BLTouch - as that sounds like it might be backwards.

The BLTouch FAQ might be helpful to diagnose:

Your last explanation was the ticket. I got everything working. The only thing is won’t keep home, even without cycling power.
The Z axis motor growls on small homing upward moves, never down. I checked the tightness of the rollers, all good.
I can re-home and Z-offset 5 times to the perfect level with feeler gauge, print the exact same test print and they’ll all turn out different (some too high, too low and just right) - it’s inconsistent.
I originally tried other firmware before I found your and those didn’t work, but the Z servo didn’t growl.
Thoughts?
And by the way THANK YOU so much for your help!! I know I’ve been a bother, but I’ll post that you guys were fantastic with trying to help me!

Tried to add a movie, but heres the audio: vankley.myqnapcloud.com/images/growling.mov
It’s the 2 sounds at the end.

That could be fine. When you’re between full steps on the stepper, it can make noises like that - and its a normal part of its operation…

Thanks for the response.
Any thoughts on why other firmware doesn’t make that noise?
Also, any thoughts on why this unit won’t keep correct home even when I do the auto home, proper Z-offset and BLTouch 5-point bed leveling? Then when I print something, sometimes it’s way too far away, and sometimes it scrapes the bed?

No worries man, this is my hobby - and I enjoy helping people where I can :slight_smile:

Not really - I’ve always had that on my printers - it just seems to be the way it is.

It could be because the SKR boards would be running a different amount of current to the steppers, maybe that’s different to the other mainboards?

What I would try is turn off the levelling via M420 S0 in your start G-code, homing the printer, move it via the screen to Z0.2 and then disable the steppers.

Move the head manually around the bed and see if it has areas where it touches or not.

Given the way you describe it, I’m wondering if its not an assembly issue - ie something is moving that isn’t supposed to - and in doing that, inducing errors.

We’re now into the difficult parts where its almost impossible to diagnose without hands-on…

Ok, I took everything loose, straightened and retightened, and it seems much better.
So everything is good except the probe works for bed leveling, but not homing…I mean it deploys when bed leveling as it should, but never deploys when homing? I though there was some gcode to tell the firmware to use the 5-pin probe port for Z homing also?
Steve

The only setting I’m aware of is at build time for the firmware… If you’re using the PROBE port, it should be set as follows:

image

If the “Use Probe for Z homing” is unchecked, it will only use the probe for bed leveling and fall back to the Z endstop for homing.

I checked that when I created it and works for leveling but not homing, or at lest I thought I did. :slight_smile:
I was experimenting with the stock Marlin firmware (to learn & test firmware options). Do you know what parameter that “Use Probe for Z Homing” is in the Marlin firmware?
Thanks again! Steve

You’re going to laugh: USE_PROBE_FOR_Z_HOMING :slight_smile:

uhhh, I don’t have that in the latest TH3D firmware sadly, can I add that?
(I’m using that firmware for testing)

And that’s the last question…I SWEAR this time!! :grin:

I can’t help you there - I don’t know how the TH3D bits are put together…

But technically couldn’t I add it in the configuration.h file…theoretically? at least to enable it and see?
What firmware is your base firmware?

Its here: