Ender 3 V2 Stock Display Icons Missing after Firmware Upgrade

Help! I am trying to upgrade the firmware on 5 Ender 3 Pro V2 machines in a high school STEM Lab. I am using the the most recent upgrade (9/10) and have tried all of the upgrades available on the current screen. I have tried this using different cards and different machines and keep getting the same result. There are no Icons on the screen as shown in the picture. These machines were purchased one year ago. I see there is no access to older firmware. I upgraded these about a month ago using the same method and everything was fine. I would appreciate any help or advice as I need to get these machines back to correct working condition.

You need to upgrade the firmware on the screen.

Grab the DWIN_SET directory from here:

Then follow Item #4 in the FAQ:

That did it! Thanks!

Sorry, no joy for me on this one. Still stays the same - no icons

1 Like

Same here, updating the display did not help.

Had to fall back to the stock firmware for now.

1 Like

It’s important that you prepare the SD Card correctly for this to work. The screen is quite picky when it comes to the format of the SD Card.

How can I prepare it wrong? Fat32 and the sole folder. Or did I miss something here?

Shouldn’t an orange screen been the confirmation that tells me that it worked?

Prepare the SD card as per the FAQ entry - just don’t use the DWIN_SET.zip from the FAQ - use the files from the above github URL.

Found the issue!

Actually, the crucial part is not to look for the orange stuff. It seems to always turn orange, no matter whether it worked or not.
The relevant part is to watch whether it turns blue first. If it doesn’t, then it hasn’t updated anything.

Btw: The FAQ entry is not usable for anyone not familiar with github. So, it would actually be useful to provide a zip-file.

So, brief version: It works! This user was just too stupid to watch out for the crucial part of the process. :wink:

1 Like

Screen is updated (turned blue for 0.1s and than orange).

I got CRC error when trying to upgrade to firmware ver. from 14.08 to something newer, maybe DWIN_SET is in fault. Don’t know.

This is true… I’m going to add a DWIN_SET.zip to the archives soon.

1 Like

tell me what im doing wrong here

  1. install Ender3-V2-BLTouch-20210916.bin onto main board (buggy and icons dont show)
  2. turn machine off
  3. remove sd card and format with sd card formatter
  4. extract contents of DWIN_SET.zip to newly formatted sd card F:\DWIN_SET\ (files)
  5. remove back plate from screen and insert sd card into slot.
  6. power on machine. screen turns blue for .1 sec then solid orange. continue to wait for 5 min just to be sure everything loaded.
  7. turn machine off
  8. remove sd card from back of display.
  9. turn machine on and find out that it didnt work.

The screen should turn blue for a number of seconds while it updates and turn orange afterwards.

If you don’t see that, then its likely not liking the format of the SD Card. Follow the FAQ entry to prepare the SD Card and try again.

I just verified myself with the DWIN_SET.zip in the firmware’s download directory and 20210917 build and all works as it should.

Really use a small SD card. 8 GB or so.
Also make sure that you format FAT32.

The display is really picky about the SD card.

Finally I managed to upgrade screen, but when I upgrade firmware to 17.09 i got EEPROM CRC error while first boot, should I be worried?
Screen is now much dimmer and has different font, can someone confirm this?

ok i figured it out after watching the creality youtube video. How to Update The Firmware of Ender 3 V2 Display - YouTube

i am using the 8gb sd card that came with the printer (Netac 8gb micro HC)

you have to use the windows formatter by right clicking on the drive in This PC and going to format

Capacity: 7.51
File system:FAT32
Allocation unit size: 4096 bytes
Volume Label: J
check Quick Format

That should get you the proper format.

1 Like

I received this same error - had to update DWIN_SET first. I can confirm the 9/16 DWIN_SET works fine with the 9/17 firmware build for 4.2.2 board (except the display is dimmer than usual). I only had a 32GB sdcard lying around, and initially DWIN_SET failed to properly flash (screen flashed blue for less than a second then orange - when it’s successful it will stay blue for a few seconds). I worked around this by destroying the partition map of the sdcard and creating a new msdos partition map (not gpt - dont know if that makes a difference but I got it working with msdos), with a single 4GB partition formatted as FAT32.

I used the parted tool you can find in most linux distros to accomplish this, eg:

sudo parted /dev/sdX mklabel msdos mkpart primary FAT32 1MiB 4GiB
sudo mkfs.fat -F 32 /dev/sdX#

Make sure to replace /dev/sdX with the actual disk device letter, and in the 2nd command make sure you replace the # with the partition number (use lsblk or similar to get this)

Yes - preparing the SD Card properly is critical. Most people who have problems are because of issues with the SD Card preparation.

Thanks a lot. Managed to get it working. Don’t format the SD card on a Macbook with DOS Fat 32 settings, it didnt work for me. Thank you CRCinAU

I had the same issue and got black screen after the update process.
To fix it, the SD Card formatting is the critical thing.
In my case with an 8 GB SD Card and partition the update don’t work at all.
After create a smaller partition (2 GB) on the SD Card, the firmware update works.

The follwing are the stepps to create the 2 GB partition on the SD Card:

  1. Connect your SD Card to your PC
  2. Open a Windows Command Prompt
  3. Type diskpart and hit enter
  4. Show the disks on your system: list disk
  5. Select your SD card using the Size as a guide: select disk number
  6. Type clean and hit enter
  7. Create the smaller partition: create partition primary size=2000
  8. Format the new partition: format fs=fat32 quick
  9. Mount the drive: assign
  10. You should now see the newly created and formatted partition in Windows Explorer. Open this drive.

And now update the firmware of the display:

  1. Download the Display Frimware Archive to your PC and extract it to the SD Card to folder DWIN_SET
  2. Insert the SD Card into the back of your screen
  3. Power on the machine
  4. On display of Ender you will see a complete blue screen for 1-2 sec.
  5. Wait for complete orange screen
  6. Power off the machine.
  7. Remove the SD Card from the back of the display.
  8. Power on to confirm a successful flash.

Hope that I will help some people that run in the same issue then I had.

1 Like