Ender 3 - v4.2.7 Board - BLTouch


First- thanks for this awesome builder and tool. The “stock” profile (Ender 3 - v4.2.7 Board - BLTouch) that you have built works great. The leveling works and everything.

I recently upgraded my Z rails with the 100mm replacements (https://www.creality3dofficial.com/products/y-axis-profiles-kit-for-ender-3-series). When I go to build my custom firmware, when I do the bilinear bed leveling, instead of going to the front right, it goes to the front left, hits the bed and then stops.

Any recommendations to mirror the exact “stock” profile (Ender 3 - v4.2.7 Board - BLTouch) but change the max Z height to 350?

Hi mate,

That’s strange - the correct behaviour should be to go to the front left for the first probe in a G29.

Check your probe offset (using M851) or via the LCD to check if it is set up correctly.

Normally, it’ll be a negative X value if the probe is mounted on the left of the nozzle.

Thanks for the reply. Unfortunately for me, i am a total newbie when it comes to this so I have no idea how to check that. I could send the BIN file to you?

On the text based menus:

Configuration → Advanced Settings → Probe Offsets

Should give you values for X / Y / Z offsets.

There’s a ton of videos on Youtube on how to find these settings for your particular setup.

This was helpful! With some tweaking, I got it done.

Any chance you have the proper pin layout for the new BL touch v3.1 sensor with the white 5 pin connector? The wires are different since its the 5 pin and not the two different connectors.


Pinout is right here: Ender 3 V2 - Frequently Asked Questions