Bed Tramming only left side on Ender 3 V2 4.2.2

Using the 20210913 or 20210908 Bed Tramming will only move to the left side or center of the bed. Selecting the right side, front or back from the LCD doesn’t have any effect.


Good find.

Is this using a BLTouch or the non-BLTouch firmware?

This is the BLTouch Firmware.

I’m guessing this is because the probe offset is not allowing the nozzle to move far enough over to get the probe to X210 for the right hand side.

If you’re able to test, if you set your probe offset to X0, does it then work?

If so, then that’s certainly the case.

That being said, I’m not sure the manual levelling is useful with a BLTouch - as it’s mainly used for checking against a Z Endstop - not the probe.

Setting the X probe offset to 0 did work. I usually tram the bed so it is reasonably close. Some smaller objects will have height deviations if I print multiple of them one at a time in the same print.

I have the same question, but I am still a noob in 3D printing. How can I set the probe offset to x0. I have access with Pronterface and know that the commands that the 3D printer understands are called gcode :wink:
Please help.

M851 is the command you want. Make sure you take note of your previous values if that’s the path you take.