Big Treetech "Smart" Filament Runout Sensor give False Positives

Hi Marlin Firmware Service,

I’ve installed the BTT smart sensors on my CR-10 S5 machines because the stock runout sensors didn’t prevent jams.

Out of the frying pan and into the fire:

The BTT often gives false positives. I updated the FW to include setting for BTT and use High Signal, but it’s still an issue on some machines. What is the correct setting? BTT+High, BTT+Low or BTT+neither?

Below is BTT recommended Marlin configuration for use with their sensors. Does the FW Builder employ these settings, or other?

Thanks so much for your service!

Best regards,


I’ve noticed that the values given by BTT in the past are very… hopeful :slight_smile:

You can change the settings at runtime via the M412 command. You can do this in your Start G-Code if you don’t use something like Octoprint or Pronterface.

I’d try the following in your slicers Start G-Code:

M412 D8 S1 R1

You can increase the value of D slightly (say 9 or 10) if you still have problems with 8mm.

I found in my testing that 7mm exactly is very optimistic.

I do use Pronterface. I’ll run that command and see if it helps. Seems like a good tip.

Thanks! Much appreciated!

  • David