Blank blue screen . .


Well . . . Things don’t seem to be going too well for me. After I resolved the problem with the filament going in the wrong direction the machine started giving change filament errors. I didn’t know what to do. I tried disabling the sensor, and tried to go back to your firmware builder, but all builds “fail” (is a technical problem on your end or is it some sort of restriction on downloads?).

Anyway, I decided I would try using the CR-10 firmware offered in your list. I uploaded it via cura, and the result is a blank blue screen. Nothing will function, it’s totally unresponsive. I’ve tried flashing it with an SD card, but nothing happens. As far as I can tell something has gone quite wrong with the mainboard of the printer. I’ve tried to connect via Pronterface and cannot. Cura cannot connect either.

I’ll appreciate your help in resolving this matter.

Best regards,


Did you ever resolve this? I have the same issue.


No, I was never able to repair this problem on my own. I contacted Creality and exercised my warranty. They were none too easy to deal with possible owing to a language barrier (that shouldn’t exist in the foreign tech support department of a company that successful -imo), or possible just due to poor service. I didn’t know exactly what motherboard the CR10 S5 had, and when I asked Creality their response was “Send a picture and we’ll tell you”. Wow! I did some digging and found out that it’s the Atmega 2560 V2.2 used in the CR10 S5 and also found out that you can’t flash that board with a SD card like you can on an Ender. They kept telling me to flash it with an SD card, and sent me an incredibly painful tutorial video for the Ender. Finally, I lost patience, they apologized and, I’m told, parts are in the mail.

The way the screen went blue is that in my ignorance I tried to flash the drive with CR-10 firmware instead CR-10S firmware. Afaict, the CR-10 firmware nuked the motherboard. Hmm . . I have no idea why this should be - totally over my pay rate. However, it’s been observed elsewhere that Creality’s nomenclature for their machines is really confusing. Basically, they’ve named nearly all their machines on slight variations of two names “Ender” and “CR-10”, but actually the differences between the machines can be very significant. In this sense, the catastrophic failure of the motherboard is kind of Creality’s fault since if they had named the CR-10S series something like “Psyche-5” (for example) it would kind of signal it’s not the same as “CR-10” whereas “CR-10S” seems like it is the same thing.

  • David

Hi David,

Sorry you couldn’t get it going - I don’t really know much about the CR10 series hardware - and its getting beyond reasonable now to physically have a printer of every model that Creality now have.

Take the Ender 3 V2 for instance - they have now shipped them with 3 different mainboards, and 3 different DWIN based screens - all with slightly different bugs that mean they need individual tweaks depending on which LCD screen you have. To make matters worse, there’s no way to tell which hardware you get without looking at the physical PCBs you received.

It seems like having a common set of hardware - even within the same model just isn’t possible for them as yet…

Maybe Creality is just constantly seeking different suppliers, manufacturers, and other contractors within China in an effort to keep their price point low. I really don’t know much about the company, but I know that the tech entrepreneur/tech manufacturing world in China is pretty “Wild West” (haha . . . “Wild East” as the case may be . . . ). I’ve been to China twice to explore the 3D printing world in Shanghai, and have visited Shenzhen also, but never met anyone from Creality. A good friend of mine says she’ll pay them a visit next month when she’s in Shenzhen.

My troubles continue with the CR-10 S5s and their motherboards (Atmega 2560 V2.2).

Last night the extruder stepper motor driver seems to have quit on one of the machines. I’ve tried using Pronterface and the LCD interface to send extrude commands to the printhead and it’s not working. I tried with a different motor, and it won’t work either so it seems something went wrong on the motherboard.

I’ve already processed two defective equipment claims with Creality, and with this new break down I might have to do a third. It’s kind of time consuming. I spoke with the vendor I bought the machines with, and they said they can replace it with a CR-10S Pro board, and they also suggested I buy a third party upgrade board by Two Trees that they don’t stock. It sounds to me if I get into upgrading the motherboards I am going to have to re-do the firmware, and re-calibrate everything. I prefer to keep using the stock motherboards that came with the machines, but I’m having issues.

My question for you is:

Can I run the same firmware if I use this board:

or will something new and different be required?

My goal in buying and setting up 7 CR-10S-5 machines was to have 6 working. Until last night I had five going, but now I am down to four. I want to get all the machines running and get my sculpture production finished. I’m just trying to figure out the most expedient way to keep on track.



To be honest, I don’t know anything about the CR-10 series printers or what they contain. I can only build firmware based on the known configurations provided here:

Okay, thanks! Thanks for that list too.

What I opted to do is just replace with stock boards because the firmware I’ve gotten from you via the Firmware Builder is basically working, and I worry that if I get some other “upgrade” board that I will spend a lot of time trying to get the upgrade to work, so I’ll stick with the devil I know.

In other news, I figured out how to correct the issue of the XY alignment going way out of whack: I physically yank the build plate (in this latest case) back into place as it prints. Better than losing 40+ hours worth of printing! :grinning: