BTT Smart Filament Sensor not working in a custom build


I used the firmware builder to compile new firmware after adding a BRR Smart Filament Sensor and I need some advice please as I’m receiving a ‘No Filament’ alert as soon as I try to print.

My printer is an Ender 3 frame with a Hemera, an SKR Mini E3v3 and a TFT35 LCD. The filament sensor is plugged into the main board and all is wired up correctly.

On both ‘Marlin’ and ‘Touch screen’ modes I checked that the filament sensor was enabled and it only gave me 2 options, either on or off. I think theres supposed to be a third option fo ‘smart’ and it’s because I can’t activate that I’m receiving the error messages.

My previous firmware builds and this build in all other senses are good, its just the sensor.

Is there something more that should have been done in the config or are there any terminal commands I could do to fix it please?

From my understanding, the TFT35 expects the filament sensor to be connected to the screen - and that you print from the screen.

If the sensor is connected to the mainboard, you’ll have to disable filament runout in the screen interface, and then turn the sensor on in your Start G-Code instead - so Marlin monitors it.