Can't Login to Site

I am trying to log in on the Marlin Firmware service but it will not let me in. I tried to log in but no matter what it always just refreshed the page to a blank login page. I tried resetting my password twice. Still does the same thing. I have a membership but I currently can’t use it because I can’t get into the site.

This usually happens if you fail the Google recapcha system.

Check your ad blocker or similar and try again.

This also happened to me. I could not log in on Firefox on my PC or my Android phone, neither of which has an ad blocker. I was able to log in using the Chrome app on my phone, though.

I am having the same issue. I can’t login on any site. I have no ad blockers or anything of the sort so I’m not sure what is going on.

I can’t see any failed login attempts at all using the email address registered in the forum.

Double check you’re using the right details, and try again.

If you still have issues, send me a private message with your account details and I’ll take a look.

For your own safety, please don’t post any of your account details in a public reply.

I seem to be having this same issue. I’ve tried logging in with ad blocker turned off as well as with chrome on my android phone (which doesn’t have any ad blocker at all) and am unable to log in; it simply refreshes to the login page. I tried resetting my password so that I know the password for sure. Same result.
Is this still an ongoing issue? Or have I stumbled into some corner? Do I need to re-donate before I can log in (I think my previous donation probably has expired by now)?

Send me a DM with your login details and I’ll see what I can see.

@CRCinAU, I was experiencing sign-in trouble this evening. I then came across your banner on the forum. I followed your instructions regarding the re-registering. I have an email from my previous signup which was on Wed, Oct 26, 2022, 7:42 PM. After my re-registration, to my disappointment, I must have been in that small group of donors that got caught in the corruption, as now I can not download the firmware files. Any help you can provide would be greatly appreciated.


Yep - can see that. I’ve restored your account and original subscription.

You should be good to go now - however you may have to log out and back in again if it doesn’t recognise the change straight away…

That worked. Thanks!

1 Like