Cant update Ender 3 (regular) v4.2.2 Firmware


Why are the Ender 3 Stock/Advance files in .hex format not .bin? Is the .hex for the older 8 bit Ender 3?

I have an Ender 3 (regular) with the v4.2.2 mainboard.

When I open the Ender 3-Stock v4.2.2 Board - Stock, the first line reads: Ender3-v4.2.2-Stock-.bin - Stock marlin configuration for Ender 3 Pro with Creality 4.2.2 mainboard.

I downloaded the .bin file to see if anything would happen and I get nothing.
Earlier today I download the Marlin 1.0.3 firmware .bin file from the Creality website, and the update worked.

What are the correct files I should download?



I was having similar confusion today as well. I just recently bought the Ender 3 (not the Ender 3 pro) At first I tried to update with the .HEX files through Cura and would lose connection to the printer. I finally navigated to the section that says, Ender 3- v.4.2.2 Board - Stock

I downloaded the .BIN file and saved it to the 8Gb SD card that came with the printer. I first formatted that card as FAT32 and then saved the file to the card so it is the only file on the card. Next, I inserted the card into the slot on the printer and powered up the printer. The screen was blank for about 30 seconds and then it started up with the new firmware.

Under printer info, it now shows “bugfix-2.0.x”

Note it also shows Ender-3 Pro v 1.5. To my knowledge this is OK. Although I’m just now running my first print. The menus are very different than stock firmware but they seem to have more features. I hope this helps. I’ve had my printer for about 4 days so I’m very much new to 3D printing.

Thanks Michael. I will give it I shot. I have only had my printer for a few weeks and learning things on the fly. I appreciate your response.