Custom firmware build BL Touch error

Wanted to update my firmware via the firmware builder. Selected all the options that have worked in the past with the exception of changing the filament sensor option from low to high. Now, i keep getting this error.

PS: BL option being selected is port

Looks like a change to the Marlin config verification bits… I’ve updated the builder, please try again.

I’m having the same issue at the moment.
Have you had any luck fixing it?

Just tried it and same error

I keep getting this error as well

It would help if people said which printers they’re trying to build for - as it could well be that the Configurations haven’t been updated for specific printers since the code change in Marlin for additional validation…

sorry, this is an Ender 3 Max with the 4.2.2 board

Mine is the Ender 3 + 4.2.7 board

Same issue with Ender 3 + 4.2.7

Ok, it looks like the issue comes from here for the Ender 3 + 4.2.7:

Here for the Ender 3 Max:

Lets see what I can do about fixing that…

EDIT: Pull Request is pending: Disable BLTOUCH_SET_5V_MODE on Ender 3 / Ender 3 Max Creality boards by CRCinAU · Pull Request #582 · MarlinFirmware/Configurations · GitHub

Many thanks CRC - Waiting on you to get my MicroSwiss working :stuck_out_tongue:

Hey CRC I see the commit was closed - any updates? I still get the same error when compiling

Yeah - I targeted the wrong branch for the PR…

Updated PR: Disable BLTOUCH_SET_5V_MODE on Ender 3 / Ender 3 Max Creality v4 boards by CRCinAU · Pull Request #583 · MarlinFirmware/Configurations · GitHub

Once it gets merged, the update will go to the builders at ~1 minute past the hour.

1 Like

I got a similar error that the customer firmware build failed. I’m trying to build the firmware for CR-10 with BLtouch and SD Cards enable. Several tries and reducing to minimal set of features but still got build failed. Could you please advise. Thanks.

4d43605c 2021-11-03 12:14:45 2021-11-03 12:15:11 Creality CR-10 Failed
9527616a 2021-11-03 12:17:27 2021-11-03 12:17:57 Creality CR-10 Failed
f870ac22 2021-11-03 12:19:46 2021-11-03 12:20:09 Creality CR-10 Failed
47784e56 2021-11-03 12:21:47 2021-11-03 12:22:11 Creality CR-10 Failed
a0cd2dfa 2021-11-03 12:23:31 2021-11-03 12:23:58 Creality CR-10 Failed

Here is the detail on error screen
Build In Progess
Build Reference: 6c515df0
Submit time: 2021-11-03 01:43:41 UTC
Last Change: 2021-11-03 01:44:08 UTC
Current Status: Build Failed!
Builder Allocated: syd-builder
Firmware is 12170 bytes too big for mainboard