E3 Pro, SKR 1.2 BLTouch New Firmware update, Lost Z?

Morning everyone,

An odd one that has thrown me.

I have just upgraded from to 2.1.1x on the nightly builds.

E3 Pro
SKR Mini 1.2
BL Touch
Dual Z axis using a Y cable
Creality Sprite Pro direct drive

upon upgrading the firmware, it seems i’ve lost the ablity to home Z?

I can move up manually but cannot move down.

When going to auto-home, it will do X and Y (blazingly fast)
but for Z the BL touch is deployed and is frantically searching for something before bugging out.

Home offsets for X and Y are good, Probe offsets are configured.

I thought maybe it was one of the nightly builds to went back to one in September and nope, still same behaviour.

I dropped it back to and it goes right back to operating normally again?

Thoughts on what this could possibly be?

it doesn’t look like I have the ability to attach files, so unable to provide the firmware.bin file I have.


The firmware won’t let you move down unless the unit has been homed first. This is a safety feature to prevent driving the nozzle into the bed.

I’m not sure what you mean for ‘frantically searching for something’ - but if you’re talking about the sense pin deploying and retracting multiple times, then its likely that the signal going back to the mainboard for pin position isn’t being detected.

Make sure you use the PROBE port and not the Z-Stop port for the BLTouch.

Hello Hello,

I could have worded it better at 4:00 AM, my Bad.

It won’t home Z.

the BL Touch will deploy but the actual stepper motors will not engage downwards.

Under that was originally running on it, it will home Z with auto home with no issues.

The current 2.1.1 will not home and throws an error on the screen

Auto Home or Home Z will not engage the steppers to start moving down.

What is the error on the screen?


I’ve just nabbed these 2 videos



same config

different firmware revisions file

Try this: Turn off printer, manually home X, Y, and Z with the printer off, making sure all end stops are fully closed. Put a fresh copy of your firmware.bin on the sd card. Reinsert sd and turn printer on, make sure it loads the new firmware.bin. Reset the eeprom. Turn printer off, then back on.

There appears to be a glitch if you load a new bin without the printer being fully ‘homed’ in all axes with the mechanical end stops engaged. Z should now behave correctly.

I fought this problem for a week on my Ender 3 MAX, seemingly randomly properly homing Z, most times not. Finally it occurred to me that Z properly homes if I make sure all end stops are engaged when loading new firmware. I have verified this problem on my particular printer with a Creality v4.2.7 motherboard. I just switched to a BTT SKR MINI E3 v1.2 as I want the BTT tft display. I got the same Z behaviour with the BTT motherboard.

I have no idea why this is a problem, I speculate something to do with resetting the microprocessor after a firmware update.

This is with my printer, of course, yours may be different, YMMV! Good luck!!

Mitch W4OA
Opelika, AL


I’m still tredding through the world of Marlin,

your comment of the Z stop made me look,

In the previous software the BL touch software was configur to use the Z stop switch and not the probe switch on the SKR mini board.

I moved it from the Z stop to the probe pin and all was happy again.
I might re-install the Z switch again as a safety measurement just incase the unit flips out.

I cannot do full mesh levelling just yet until I get a shorter bolt for one of the wheels on the direct drive unit gantry.

Happy to say i’ve got it mostly sorted now, apart from fine tuning the probe offsets.

Thanks again!

1 Like