Ender 3 Max with an SKR Mini E3 V2.0, a BLTouch, filament sensor firmware?

No worries man, this is my hobby - and I enjoy helping people where I can :slight_smile:

Not really - I’ve always had that on my printers - it just seems to be the way it is.

It could be because the SKR boards would be running a different amount of current to the steppers, maybe that’s different to the other mainboards?

What I would try is turn off the levelling via M420 S0 in your start G-code, homing the printer, move it via the screen to Z0.2 and then disable the steppers.

Move the head manually around the bed and see if it has areas where it touches or not.

Given the way you describe it, I’m wondering if its not an assembly issue - ie something is moving that isn’t supposed to - and in doing that, inducing errors.

We’re now into the difficult parts where its almost impossible to diagnose without hands-on…

Ok, I took everything loose, straightened and retightened, and it seems much better.
So everything is good except the probe works for bed leveling, but not homing…I mean it deploys when bed leveling as it should, but never deploys when homing? I though there was some gcode to tell the firmware to use the 5-pin probe port for Z homing also?

The only setting I’m aware of is at build time for the firmware… If you’re using the PROBE port, it should be set as follows:


If the “Use Probe for Z homing” is unchecked, it will only use the probe for bed leveling and fall back to the Z endstop for homing.

I checked that when I created it and works for leveling but not homing, or at lest I thought I did. :slight_smile:
I was experimenting with the stock Marlin firmware (to learn & test firmware options). Do you know what parameter that “Use Probe for Z Homing” is in the Marlin firmware?
Thanks again! Steve

You’re going to laugh: USE_PROBE_FOR_Z_HOMING :slight_smile:

uhhh, I don’t have that in the latest TH3D firmware sadly, can I add that?
(I’m using that firmware for testing)

And that’s the last question…I SWEAR this time!! :grin:

I can’t help you there - I don’t know how the TH3D bits are put together…

But technically couldn’t I add it in the configuration.h file…theoretically? at least to enable it and see?
What firmware is your base firmware?

Its here:

I’ll be a SOB - IT WORKED!!! :joy:
Thank you, thank you, thank you!!!

1 Like