Ender 3 Max with an SKR Mini E3 V2.0, a BLTouch, filament sensor firmware?

I have an Ender 3 Max with an SKR Mini E3 V2.0, a BLTouch (5-pin-not split pins) and the stock Max filament sensor. I’ve tried the Ender 3 with the SKR, and a modified Ender 3 Max with 4.2.7 - none worked. The Ender 3 Max one almost worked but it’s still looking for the Z limit switch.
Is it possible to make a firmware for an Ender 3 Max with an SKR Mini E3 V2.0, a BLTouch (5-pin-not split) and the stock Max filament sensor?

You might be able to do this via the Firmware Builder - however you’d need to pick the Ender 3 with SKR E3 Mini v2.0 mainboard - but change the bed dimensions to match the Max.

You’d also need to select the correct filament runout options.

I believe the rest is similar enough that it should just work.

I tried that (end 3 w/SKR) and set the bed at 300,300,340, but it didn’t work as it was still trying to use the z-stop even though ticked “use probe for z home”?

Did you tick the ‘Use Probe for Z homing’ option?

Otherwise it will still use the Z-Stop for homing, but the probe for G29 etc.

Yes, see answer above

On my Ender 3 Pro (old printer), the BLTouch was used for everything, z homing and bed leveling…that’s not the case with the Ender 3 Max?
But I was using the TH3D Unified on that printer.

Also, if I create a firmware, is there a way to enable the “Z Offset Wizard” on the LCD?
One LAST side question, is there a webpage which explains all the settings on the LCD…some are unusual, like fade?
Sorry for so many questions.

So to recap:
Ender 3 Max with an SKR Mini E3 V2.0, a BLTouch (5-pin-not split pins) and the stock Max filament sensor firmware.
Enable the “Z Offset Wizard” on LCD
Use probe for all homing and leveling (not z-stop)
Doing leveling on my Ender 3 Max, the printer homes correctly, but the BLTouch probe starts too far forward off the bed (and fails)

Your problem with the nozzle / probe being misaligned is probably due to no Probe Offset being set.

You can set this via M851 or in the text menu:

Configuration → Advanced Settings → Probe Offsets

The Fade Height is explained in the M420 command documentation.

Thanks.
But what about my other question? Can that firmware be made?
Ender 3 Max with an SKR Mini E3 V2.0, a BLTouch (5-pin-not split pins) and the stock Max filament sensor firmware.
Enable the “Z Offset Wizard” on LCD
Use probe for all homing and leveling (not z-stop)

Yes, these options are already available in the Firmware Builder to allow that to be built.

However as mentioned, use the Ender 3 preset and change the bed size to suit the Ender 3 Max.

I don’t see an SKR option, only 4.2.2 & 4.2.7?

As mentioned, use the Ender 3 preset and adjust your bed size / build area to suit. You should be able to select the correct filament runout sensor options as well.

My apologies, you’re right. I’ll try that one.
The big problem is that when I do set the BLTouch for Z homing, as the Z gantry is coming down, I push the BLTouch pin and it sucks in but the gantry continues to drop until it hits the Z stop limit. It’s almost like the BLtouch is powered up but the firmware isn’t looking for that input, but still using the Z endstop switch.
Here’s settings I’m using:

If that’s still the case, I would check the black/white part of the cable on the BLTouch - as that sounds like it might be backwards.

The BLTouch FAQ might be helpful to diagnose:

Your last explanation was the ticket. I got everything working. The only thing is won’t keep home, even without cycling power.
The Z axis motor growls on small homing upward moves, never down. I checked the tightness of the rollers, all good.
I can re-home and Z-offset 5 times to the perfect level with feeler gauge, print the exact same test print and they’ll all turn out different (some too high, too low and just right) - it’s inconsistent.
I originally tried other firmware before I found your and those didn’t work, but the Z servo didn’t growl.
Thoughts?
And by the way THANK YOU so much for your help!! I know I’ve been a bother, but I’ll post that you guys were fantastic with trying to help me!

Tried to add a movie, but heres the audio: vankley.myqnapcloud.com/images/growling.mov
It’s the 2 sounds at the end.

That could be fine. When you’re between full steps on the stepper, it can make noises like that - and its a normal part of its operation…

Thanks for the response.
Any thoughts on why other firmware doesn’t make that noise?
Also, any thoughts on why this unit won’t keep correct home even when I do the auto home, proper Z-offset and BLTouch 5-point bed leveling? Then when I print something, sometimes it’s way too far away, and sometimes it scrapes the bed?