Ender 3 Pro - several questions

I have an Ender 3 Pro with a 4.2.2 logic board that I bought in February and am still trying to get it to work. When I bought it, I also got a CR-Touch and put it in right away, before doing anything with the printer. I now suspect a major problem is the CR-Touch is bad. I’ve taken it off and put the Z limit switch back on. My problem is that when I upgraded to the CR-Touch and downloaded the Creality firmware for it, it garbled my LCD screen when I installed it. I asked Creality for help and they sent me more firmware files that wouldn’t even load. I’ve used 3rd party firmware files, but they won’t work without the CR-Touch.

So I’m joining here to get my own firmware and have a few questions:

  1. I have an Ender 3 Pro with a 4.2.2 logic board. I see an 8 bit Ender 3 Pro in the lists of firmware I can download, but I don’t see one for a 4.2.2 logic board. Will the “normal” Ender 3 file for 4.2.2 work? (The one without a Touch probe?)

  2. It looks like, from what little I’ve seen about configuring options, that one can compile a firmware file for a probe or to not use one, but not a firmware that would work for both. Is that correct?

  3. I went through a tutorial and compiled my own firmware file with Visual Studio. The build process was successful, but when I put the file on the SD card and started my Ender 3 Pro with the card in it, I got a long beep and nothing happened. The screen stayed blank. With some Creality firmware files, the screen just stays blank. What is happening inside when the screen stays blank and what does the buzz or long beep I get mean?

  4. Any idea what is going on to make some of the Creality firmware files give me gibberish on the LCD screen?

    I’ve been told that this problem seems to show up on some Creality printers with a 4.2.2 logic board where the ARM chip has a specific number that’s not the same as for the normal chip. In other words, due to supply shortages, some boards have a substitute chip in them and they may work with the included firmware, but not with any other (without the garbling). Does anyone have anything useful on that situation?

To answer one of your questions, the firmware you should be using on the 4.2.2 board with CR touch is the “Ender 3 Pro 4.2.2 - BLTOUCH”

I’ve removed the touch probe. Should I still be using one for the BL-Touch? But in the list of pre-built, I don’t see any Ender 3 Pro listed except the 8 bit. On the builder, it’s the same. I don’t see any other version of Ender 3 Pro listed. I’m wondering if there’s another page I’ve missed.

If you’re not using the Touch then you should use the Stock profile. The Ender 3 and Ender 3 Pro use the same firmware so use the Ender 3 profiles.

Thanks! That was my guess, but I wanted to be sure about it. I put my CR-Touch on before I even started printing, but I have yet to get a good print and I’ve checked everything else, including using levels to check all gantry parts, so either my glass bed is so warped ABL won’t work or something’s wrong with that Touch probe.

Well, it turns out the question is moot. I finally found out why my Ender hasn’t been able to print, no matter what I’ve done, for the 5 months I’ve had it. I have a GD chip, not an STM, and the GD chips are not direct replacements. One of the things they cannot do is handle the code that controls the Z-Offset issues. That’s why, no matter what I did, I could not print a consistent 1st layer. Marlin can’t, at this point, support the GD chip because they don’t have the rights to the needed libraries.

I did try the firmware I downloaded from here, using it without my CR-Touch, but it didn’t include any tramming wizard or anything to help me do any alignments. I finally found a firmware version I could use to print without the CR-Touch, then I re-installed my probe and finally got an auto-bed level and good prints.

What firmware did you finally end up using that worked with your CR-Touch? I believe I am having similar issues.

Going to take a few steps to get to the answer - since it probably helps to understand what’s going on.

I went through this thread and spent time actually studying it and tracking who was saying what. It helped me understand that what I said in my last post on this thread was correct. Creality made everything for the STM chip, then changed to the GD chip and, on doing so, did NOT update a single thing to make sure their normal firmware worked with the new chip. (I have it on good authority that Creality has upgraded to an even worse chip or chipset that has more compatibility problems.) They haven’t announced this or given their customers any guide to deal with it.

So I went through that thread on the issue/bug and looked for the posters that knew what they were talking about and then downloaded firmware from some of them. I found some that booted but didn’t work and finally found that the one from H5Labs was booting and actually worked. After 5 months, I finally printed my first good test print and actual item on my E3P! If Creality had been honest about this, I would have been able to do this back when I bought it. And, yes, this firmware did work with the CT-Touch.

I don’t remember the exact link that got me the good file from H5Labs. It may have been a file included in one of his posts on that thread about the issue, or it may have been from their own website. Sorry I can’t be more specific. I was frustrated and going through firmware file after firmware file to find what worked. When downloading, I tried to make sure I had specific names, but I forgot which one I finally used when I copied it to the SD card as firmware.bin. I just remember it was from H5Labs.

I had given up on getting my E3P to work - and if I had just gone by what Creality was telling me, it never would have worked. (Couldn’t use the CR-Touch and the files they were sending me wouldn’t work - just garbled the LCD display!) I had already spent a lot on fixes and add-ons and wasn’t going to spend more. Once the H5Labs firmware worked, I went to TH3D studio and bought one of their logic boards and probes (to replace the CR-Touch). I haven’t had time to do more than just test the E3P out with their stuff, but it behaves much better. I’ll be able to do more testing and start using it when I finish a few other things. Their people on their online chat are amazingly knowledgeable and helpful. I just wasn’t going to buy more for that printer until I knew it would work at all. The H5Labs firmware finally proved that.