Ender 3 SKR 3 Mini E3 V3 problems with Jerk and som other minor issues

At the start of the year I used the builder to make a firmware with the builder. Which worked fine and I was/am happy with it. I really like how easy it was to build a firmware.
Lately I got problem with ringing and wanted to check out “Input Shaping”.
Loaded my old profile into the builder and just added Input shaping, error… after some search I found a parameter in PID Temperatur had changed to BANG something something, changed it back to 255 and it worked.

After installing the firmware more problems.

  • Sound from button press is muffled (some may like it some don’t, I got used to the loud beep)

  • Bed Leveling takes longer due to the Z axis moving up an additional 6 mm after a probe. The upward motion is not the problem but it moves the 6mm slow down again. My start gvode always makes a new mesh so this will increase the time of a print.

  • Jerk settings are not changed at least E-Jerk is 15.00 on the printer is set to 5.0 in the builder

  • My Z Jerk was set to 0.39 in the old build. If I set it to 0.39 in the new builder it is set to 0 on the printer and I can only change it by full numbers so to 1.00

  • Font changes when editing a menu point (taller and slimmer) I am not a fan but I think this is one of the points that is not really important.

I do understand some things change but at some of the things I am unsure if they are intended or a bug.
Atm I went back to my old build wich I luckily still have on my computer.