Ender 3 v2 abl not working

Hello, I’ve been using this firmware service for a while and it has mostly been good. However, there has been one major disappoint. That being, I have all of the abl features on the LCD, but when it comes to printing, it probes for mesh prior to displaying that mesh. Then proceeds to not use that mesh what so ever in the print. This has been incredibly frustrating (especially since this is a paid service), and I’m honestly hoping I’m doing something wrong to cause this.
The firmware is for the ender 3 v2 bltouch. I have tried reflashing, still not working.

That’s likely all set in your Start GCode from your slicer.

Make sure there is an M420 S1 in there after the G29.

Here is my start gcode. I tried using your start gcode but it will not even print. After warming up and probing the mesh it lowers the nozzle and moves very slowly (practically not at all) while pouring filament out.
Thanks for the help.
; Ender 3 Custom Start G-code

G92 E0 ; Reset Extruder

G28 ; Home all axes

G29 ; auto bed leveling go!

M420 S1 ;

G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed

G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position

G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line

G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little

G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line

G92 E0 ; Reset Extruder

G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed

G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish