Ender 3 v2 Custom Firmware build, 285C Max temp need help


I tried building a custom firmware for E3V2 with 285C max temperature but when I try to install it I get a black screen. I was successful in installing the premade firmware when I tried to check if my method of installation has errors. Any ideas on what might be causing this? All are default except for these areas where I included features.

Adaptive Step Smoothing
Classic Jerk
Firmware Retract
M78 Print Counter
S Curve Acceleration
SD Card Support
Enable MeatPack Support
Enable Power Loss Recovery

There are now 3 different mainboards and screens that Creality sell as the Ender 3 V2 now.

Which mainboard and display revision do you have?

I bought mine back in January 2021. I have 4.2.2 for board and the screen, I have a non-touch screen.

There are also 3 different types of screens.

Given yours is fairly old, its likely before any of the parts changes. Go through the screen firmware update process and see if that resolves your issue.

So when I install the firmware, leave the black screen be and proceed with the DWIN setup? I did patch my screen with your provided DWIN back when I used the Marlin firmware service firmware the first time but I’ll try it out.

Hi, it didn’t work. Any other thing that might be wrong with the build I made?

If you flash the normal nightly again, does it work correctly?

Earlier yes, I haven’t reflashed yet.

It works with the normal nightly patches.

Ok, stick with that for the moment… I’m on vacation until the end of the week, so I’ll try to catch up and see if I can find anything when I return.

Alright, Thanks for the help!