Ender 3 v2 screen Portrait/Landscape

I’ve just updated my two ender 3 v2’s to latests daily configs, both are BL touch, one is 4.2.2 and the other 4.2.7

I’ve also updated the screen firmware with the DWIN_SET download.

The 4.2.7 gave me a landscape screen - I couldn’t see how to change this so printed a horizontal mount and now quite like the landscape view

The 4.2.2 has given me a portrait view, but the information is only showing in the top 55mm of the screen, with some menu items appearing off screen. It’s as though the screen is running in landscape mode, but portrait orentation - is there a simple way to fix this?

That’s weird - but there’s been a lot of churn at the moment as we move to bugfix-2.1.x now…

I’ll try to take a look today and see if I can replicate the problem…

I just loaded Ender3-V2-BLTouch-20220608.bin on to my v4.2.2 Ender 3 V2 - and I can’t replicate your issue here.

Try a reformat of your SD Card, load the DWIN_SET again, and then rename the firmware and try flashing again.

I didn’t update the DWIN_SET on mine - but I’ll give that a go again too.

In case you have a different screen than me, try taking a photo of the back of the screen and posting it - apparently there are at least 3 different screens being supplied by Creality - all of which have their own quirks…

Oh, you can always try the MarlinUI version too - and see if that works correctly.

Ok, I tried re flashing firmware on both screen and printer - same result.

I then plugged the screen in from the other printer - and it works as you would expect! So it’s definately to do with the screen it’s self.

Photo of the output also

Interesting… Does the non-MarlinUI version also do the same and try to display in landscape instead of portrait mode?

Oh, and if you hit the button to go into the menu, does the menu draw in the correct orientation?

Ah - I think I might have found the problem… I’m running a new set of builds manually… Try grabbing the MarlinUI version again in ~25 minutes…

1 Like

You think it’s firmware not LCD firmware problem then? Wouldn’t that be weird considering my other LCD works fine?

Right now, I’m not sure - but it seems like two problems…

One that the default MarlinUI sample configuration seems to enable MarlinUI in Landscape mode - which is wrong.

But there may also be a problem with the rotation on that display… Hopefully, when this build finishes, you can test and see…

Sadly, Creality are cranking out different versions of the screen with different hardware, and all seem to have their own quirks…

Ok, new builds for today have been pushed… Grab the MarlinUI one and see if it displays properly on both screens…

It’ll be the same filename, so you’ll have to rename the new file for the printer to load it…

Ok, will do, just need to let this print finish so won’t be for a couple of hours. But will report back (suspect you’ll be offline in Auz by then (I’m in the UK)

Is the file name not different anyway, as it’s a different date?

Nah - filename is the same as the date is based on Aussie time :smiley:

I couldn’t get the 20220608 to load - but the 20220609 was there and that’s solved the problem

Worth noting the 4.2.7 is defaulting to landscape also


Yep - the change I made should affect all printers with the DWIN based screen for MarlinUI.

A post was merged into an existing topic: Ender 3 V2 Stock Display Icons Missing after Firmware Upgrade