Ender 3 with CR Touch - After Installing Custom Firmware I Cannot Use Bed Leveling GCODE

What the title states.

Last night I installed a recent Ender 3 4.27 with BL/CR Touch firmware and I am enjoying it.

The only issue I ran into is that from time to time I like to run CHEPs Bed Level M25 GCODE to do a bed level along with setting my Z Offset for the CR Touch. NOTE: This isn’t an STL file, it’s just the code that moves it to 5 points on the print bed for wheel/spring adjustments.

With Creality’s latest official firmware, this GCODE file worked perfectly. You’d run it and then press resume after each touch point to manually adjust the bed.

With this new Firmware when I run the bed level file it starts off fine, but when it goes to the first point it hangs there and the LCD screen says:

Print Paused


The only way to get it to get off that screen is to turn the machine off and on again.

Any advice on how to get it to work?

SIDE NOTE: I know there is a Tramming Wizard, but I wasn’t entirely sure how to use it properly. I assumed it was a matter of making sure the Front Left/Right and Back Left/Right measure to 0.00 but I wasn’t able to find any documentation explaining the process. So if that’s a solution, I would very much appreciate a nudge in the right direction so I can use the tool correctly.

Thanks a lot in advance and I look forward to any suggestions.

I believe there’s a different version that uses a different command instead of M25.

Give that one a whirl.

I just want to say thank you for that suggestion. I grabbed another bed level file off of Thingiverse and it worked perfectly.

Sorry for the late reply!

1 Like