Ender 3v2.4.2.7BLTouch 400XL custom firmware issue


After a few days of playing around in platformIO I was directed to the custom firmware builder. I created it successfully and for the correct board but no matter what I do when I flash I get a beeping error. I even tried with just the BLTouch and 400x400x500 bed size variants enabled. Any help would be appreciated. I’ve not had luck in learning how to make my own firmware, there are always issues with it and any firmware I find online also gives me the beeping error when flashing. Any help would be appreciated.


Hi did you manage to get it working? I just installed the extender kit but have no way of making the printer use the full bed its still thinking its got the 220x220 and the bltouch wont prob correctly ive attempted the custom firmware builder on the site but when i try to flash it i just get a blank screen…


So there are a few things that aren’t really mentioned in the EE XL guides.

I am assuming you are using cura? If so then you will need to remove the restrictions. Video below I used and it fixed everything.

So I had to download and compile the Bugfix2.0 firmware. I had a lot of issues but I believe I have it working now.

One guy had luck using making firmware from the group I’ll post a link to below.

There are modifications you have to make that are not in any guides online though. The marlin bug fix 2.0x precompiled firmware for the ender3v2 does not have the proper board set up and that has to be changed to whatever board you have. The one that is setup is 4.2.x and the motors are unresponsive to that one. So add a 2 or a 7 to the end of that depending on which board you have. When you go to compile Mega(4 numbers I can’t remember) will flash an error and it will tell you to change that to an STMP(more numbers and letters I can’t remember) Make all of the nessecary changes for your printer, flash the machine, then reflash the screen firmware. That worked for me.

It took me a little over a week of playing around in my off time to figure everything out and get it all working properly. The TH3D seemed great and very beginner friendly but I didn’t have much luck. The Marlin Bugfix 2.0.x I was working on had an issue that is still unexplainable. I redone loaded and started from scratch and it worked the first time. If I remember correctly, you should only need to work in boards.h, configuration.h, and maybe configuration.h advanced files. Definitely turn on unified mesh leveling.

Good luck and I hope this helps.

I also don’t know how much experience you have with visual studio code but when you go to compile it will tell you what issues you have. The guy in the video below has the most steps out of all of the guides I have found.

I dont understand visual c,coding or hex. Im aware of the cura settings thats all done i can use the whole print bed while printing but my blt touch isnt probing the whole bed which basically makes it useless . Its connected via the pins on the 4.2.7 board.

i manage to get the custom build files to work apparently the file names had been too long but now the printer wants to print to the far left front in mid air… I place a thread for a feature request or what not in hopes someone can make the file cause ive spent all day at this with absolutely no luck in getting it to work properly i dont know what i am doing i dont know what options do what and before i grab this thing and toss it in front of a train im just gonna have to deal with no BLTOUCH and just do the Chep video mode to use the full 400x400 bed. I am frustrated and ive used up credits made several custom build files with no luck so hope somoene can help or share their file if theyve already got a similar setup.

I have an Ender 3 Pro with Creality silent board 4.2.7. BLTouch and the bed deminsions are 400x400x700.

It sounds like you’re just about there - you only need to set the Z-Offset.

I’m waiting for one more patch to be approved upstream, then the Z-Offset wizard will become available on the Ender 3 V2 screen via the builder. Likely this will make your life easier too.

Following on from this - the new UI is now active for the Ender 3 v2 in the builder - so you should have the Z-Offset wizard available in the menus now.

1 Like