Ender 3v2 with bltouch firmware

Hi everyone.
With firmware 2.1.0 all was working fine. Starting with firmware 2.1.1 till now firmware with bltouch not working properly. Bed tramming wizard and manual bed tramming problems with right side of bed. Offsets are set properly, but printer thinks that tramming points are outside off bed. With left side all is ok.
It seems, that there are some changes starting with 2.1.1 firmware and these changes are not properly set in config files for ender 3v2 with bltouch.
From downloaded versions Ender3-V2-BLTouch-20220330 works as expected, but Ender3-V2-BLTouch-20220629 not working. Also tried latest version, but still not luck.
Thanks!

My presumption is that older builds was made with different tramming points.
If yes, may be this could be corrected.
Thanks!

The configurations come from:

I believe that the probe points only work correctly when the probe offset is set to X0 Y0.

If you temporarily set your probe offsets for X and Y to 0, does it work as expected?

With probe offsets X0 Y0 right side works, but left side not. Probe moves too far to the left outside bed.
With correct offsets when moving to right side printer says “Z Probe Past Bed”.
I made little digging with conf files with diff. They look like quite similar. It may be marlin bug also.
May be some one can check this on another creality printer. It’s interesting problem is only on ender 3v2 with board 4.2.2 or this is global problem.

Ahhhh - yes. The probe points set in the Creality style menu are configured within the UI libraries.

Have you tried the MarlinUI version of firmware?

Thanks for answer.
In marlin UI I can’t find option to tram bed with bltouch. Only option I found where you need to check every point with piece of paper:( And yes, head moves without bltouch offsets.

Hi,
I can confirm I cannot tram the right side of the bed with probe offsets applied, or the left side (misses the bed) with 0,0 set as x y offsets.
SKR-Mini-E3-v3-BLTouch-20230128.bin
Ender 3.
Also while I’m here @SilverAG if I can, you mentioned diffing the config files - how to you get them please? I can use the crc.id firmware builder or download the precompiled bins, but cannot see the config.h, config.adv files of those bins (such as SKR-Mini-E3-v3-BLTouch-20230128.bin).

A diff might help with the hellish issues I’m having getting a UBL mesh to complete compiling my own 2.1.x firmware. It fails at probe 50ish /100 with M112 errors. Wires, probe, are good and the glass bed is level. It’s driving me nuts!

Thanks!

I completed tramming by setting offsets and tramming via octoprint.
Test whatever offset numbers get you as close as possible to the corners before it refuses to tram that side. Mine are below. I have a home offset of 2, 16 though.

  1. Send M851 X-55 Y-55 then tram the right front corner and click done. This is your 0 z level. Other measurements are based off this

  2. Tram the right back corner. Adjust and measure until its 0.

  3. Send M851 X-55 Y-10 then tram the left front corner. Adjust and measure until its 0.

  4. M851 X-55 Y-55 then tram the left back corner. Adjust and measure until its 0.

A positive number - raise bed
A negative number - lower bed.

I found solution. Tamming feature is not in marlin firmware, but ProUI interface.
Modified dwin.cpp with my offsets and compiled myself.
I think, that there is option to use firmware offsets, bet I used already measured numbers.
Attached my modifications:

// Bed Tramming

void TramXY(const uint8_t point, const float &margin, float &x, float &y) {
switch (point) {
case 0:
LCD_MESSAGE(MSG_LEVBED_FL);
x = y = margin;
break;
case 1:
LCD_MESSAGE(MSG_LEVBED_FR);
x = X_BED_SIZE - margin - 33; y = margin - 45;
break;
case 2:
LCD_MESSAGE(MSG_LEVBED_BR);
x = X_BED_SIZE - margin - 33; y = Y_BED_SIZE - margin - 45;
break;
case 3:
LCD_MESSAGE(MSG_LEVBED_BL);
x = margin - 33; y = Y_BED_SIZE - margin - 45;
break;
case 4:
LCD_MESSAGE(MSG_LEVBED_C);
x = X_CENTER; y = Y_CENTER;
break;
}
}