Ender3 V2 Firmware Locks/Requires Power Reset whenever Attempting to Heat up Hot End!

I am an experienced 3D Printer user who has been using your service for a couple years now. I cleared the dust off my Ender 3 V2 printer and updated the firmware, expecting it to work flawlessly as usual.
The firmware I used is the Ender3 V2 4.2.7mainboard with BLTouch. (Ender3-v2-v427-BLTouch-20230719.bin)

I updated my x, y and z offsets and attempted to load filament. As soon as I pressed the button, I get an error stating the “hotend or bed temperature is too low.” It absolutely would not let me do anything beyond tinkering with the settings. I even tried lowering the minimal temp to zero (0), and that did nothing. I did several power resets and it did the same thing every time. The Alarm beep is loud and annoying, btw… I tried manually setting the temperatures. The bed would accept a temp and responded. The hotend itself gave that same crazy error every time, with some mintemp error.

 Frustrated, I downloaded the Marlin version of the firmware and although the menu is a bit different, it's working flawlessly. All offsets are installed and it is now printing a test. 

 In my opinion, the firmware should work with minimal adjustments, setting offsets, etc. The default temps should be good enough for basic tests, such as printing a test cube in the center of the print bed. In the past, I'd update this firmware, make the offset adjustments and then print something a few moments later. Whatever this PRO stuff is, it renders my printer unusable.

possible problems and solutions.

1- broken thermocouple.
solution: replace thermocouple.
2- wrong thermocouple connection.
solution: check thermocouple connections.
3- wrong thermocouple sellection on marlin
solution: sellect correct thermocouple on marlin fw
4- wrong PİD calibration
solution 1: manually calibrate PID values
solution 2: autotune PID (PID autotune | Marlin Firmware)

i hope this solves your problem.

I think I need to repeat my problem. I downloaded the standard Ender3 V2 with BLTouch and .4.27 mainboard firmware. It refused to work and immediately generates the error “hotend or bed temperature is too low.”

After fighting with this using all the techniques you identified, it still does not work. I THEN downloaded the MARLIN version of the firmware. The UI is quite different, yet it automatically worked perfectly. I did the offsets and then did a print test cube, which worked perfectly.

The problem is NOT the Thermocouple or any of the connections. The firmware was IMMEDIATELY, (like less than half a second) generating the error message, without doing any kind of heating at all.

I strongly believe there should not be any expectation of doing PID calibrations or tuning the PIDs before anything is printed. You need to be able to TEST that the firmware WORKS first and then go about optimizing it with the tuning. It should work when first installed with average settings.