Filament load and unload length

I just upgraded to 4.2.7 on my Ender 3. I compiled firmware using the builder. Now I can only set these lengths to a max of 200mm. How can I fix this?

1 Like

I have the same issue. Iā€™m not confident enough to compile my own firmware from scratch. It would be nice if the configuration in the Firmware Builder had a few more configuration settings such as: #define EXTRUDE_MAXLENGTH so this could be adjusted without messing up the other settings.

Or if the configuration was available for edit as an advanced option prior to compiling and downloading.

The 200mm default setting is way to short for a lot of CR/Ender Bowden style machines. At least I would request this be moved up to 500mm to cover most instances and still provide run-away protection.