Filament runout sensor always triggers

I was trying to make a firmware with a filament runout sensor and no matter if I set it to trigger on LOW or HIGH when I have it turned on it always triggers after about 5 seconds and starts the filament change sequence. Anybody know what I am doing wrong?

Thank you.

Might be a problem with your runout distance being insufficient or the setup is just wrong.

You can use M119 to check the state of the filament sensor as Marlin sees it - check it with both the filament installed in the sensor, and without.

I have the same problem. I’m using a 2 wired microswitch for sensing (Common and N.C.)
When I send code M119 through Octoprint it says triggered when filament is present and open when not present. I assume that is the correct way on the switch. Regardless of whether the filament is loaded or not the filament change process is activated at the start of the print and will do it again after I perform the sequence. I’m using Marlin bugfix-2.0.x 2022-05-14. My printer is an ender 3 , board 4.2.7, with BL-touch also, which works fine.
Any thoughts? I am only able to load firmware via SD card, no programming experience.

If you’re using the nightly builds - they only support a motion based sensor.

If you are using a microswitch, you would need to build a custom firmware via the builder with the correct options for your runout sensor.

1 Like

So I’m new to this. If I want the nightly build plus the modified sensor option as mentioned will the builder default to all the other nightly build options or do I need to learn what they are?
I looked at the builder and I don’t know what to select for the BL touch probe etc. Basically I’m looking for the nightly build for ender 3 - 4.2.7 board and BL touch with an option to change the sensor type.
Thank you.

At the moment, yes.

In the future I would like there to be an option to import the nightly configs - but it isn’t possible yet.