Firmware build failed, no error message :-(

Hello all! New member, I have a CR-10 Mini with a 4.2.7 board, bl Touch and a Micro Swiss DD and hot end. Seeing as using CR-10 in the firmware builder sets me up with the original Melzi board, I selected an Ender 3 with a 4.2.7 board and changed the bed size and tried twice ( builds 9742aea0 and c614e08a ), both failed with no error listed. Any ideas?
Thanks for the service and this great site!


Thanks for the reports and the build IDs… It looks like there’s a current issue with the Upstream default configurations - which is throwing an error.

It looks like the additional #endif here is breaking a lot of configs:

I’ll speak to a few folks and see if we can get it resolved sometime soon…

1 Like

Hey gang,

I have an Ender 3 Pro with 4.2.2 MB and a CR touch with an upgraded ender extender 400x400 build plate.

I am trying to get a firmware with a 5x5 grid bed level for the full build volume.

I tried the Firmware Builder a ton but it fails every time. I tried my hand at modifying myself using Visual Studio…and well…here I am lol

Any help would be greatly appreciated!!!

What is the failure message? Do you have any of the build IDs I can track down to see what might be happening?

EDIT: I think this is the same as another thread - so I’ll merge the two…

Thanks a ton!

a81517dc 2021-12-05 16:06:33 2021-12-05 16:06:37 Creality Ender 3 Pro (8 bit board) Failed
288b82ca 2021-12-05 16:07:08 2021-12-05 16:07:19 Creality Ender 3 Pro (8 bit board) Failed
5c4673fe 2021-12-05 16:08:46 2021-12-05 16:08:55 Creality Ender 3 + v4.2.2 Mainboard Failed
80b0e4ae 2021-12-05 16:09:25 2021-12-05 16:09:28 Creality Ender 3 Max + v4.2.2 mainboard Failed
0b0999fc 2021-12-05 16:14:03 2021-12-05 16:14:10 Creality Ender 3 + v4.2.2 Mainboard Failed
5a5327ca 2021-12-05 16:22:49 2021-12-05 16:22:55 Creality Ender 3 + v4.2.2 Mainboard Failed
70569232 2021-12-05 16:23:23 2021-12-05 16:23:27 Creality Ender 3 + v4.2.2 Mainboard Failed
7ed4200e 2021-12-05 16:24:02 2021-12-05 16:24:07 Creality Ender 3 + v4.2.2 Mainboard Failed
e73a30ea 2021-12-05 23:58:06 2021-12-05 23:58:17 Creality

Issue report is now here: [BUG] As of 10 hours ago, all Configuration_adv.h files are broken · Issue #627 · MarlinFirmware/Configurations · GitHub

Linked issue has been fixed - builder should now be functional again.