Firmware with CR-touch wont operate!

I have an Ender 3 pro. Upgraded to a 4.2.7 silent board, an Ender direct drive, and the problem child, A CR touch. I’ve been wrestling with the touch for 4 months. Problem is definitely the firmware (maybe??)
.I have tried Every one that even remotely has the same config on both the Marlin and Creality sites, plus 3 different versions from Crality customer support… The ones that work at all , all seem to have the same issue. Load up fine, will test move all axis ok, then when I try to auto home it moves Z up, X and Y zero then center of plate. but will not deploy the probe, after some time “stopped” is displayed on screen and now Z axis won’t move down. I can move up, but not back down, even to where it started. Checked wires and they look like all the pictures. I can reflash back to a non touch firmware and manually level just fine, all axis will go both directions.

I’ve tried 3 different touches and all do the same thing. I tried upgrading to the SKR mini pwb, twice, the Color touch screen, then finally Back to the original setup. I’ve downloaded 50+ firmware’s with no luck.
Please help, I’m getting tired of looking at this boat anchor.

Jason Istas

Hi Jason,
I have been trying to get my bltouch to work on my Ender 3 pro, SKR mini E3 v3.0 with direct drive. I got everything to function except for homing properly. After doing the bed leveling the probe would go to the center of the build plate and stop. It would start the print from the center of the bed. The hot end would crash into the right of the build plate and start printing there.
Danny Perkins

1 Like

Same with ender3 pro with 4.2.7 board ,put v2 software on to work with v2 display,worked well but filament sensor I fitted not put v2 for fs and bl touvh on ,no go ,goes to sentre of bed and stops. I havent got bl bl touch software crook.waste of time in my opinion.just use old method of bed levelling. If in n doubt,go back to original firmware for the board you have,which i did.

1 Like