Input Shaping missing Y axis

After building a firmware with Input Shaping enabled, only the X value is present, I’m unable to change or set the Y value (tried both console and UI).

Can you give this a go at the console, and include the comms with Marlin?

The current documentation is here:

If you can also include the output of M593 with no parameters as well between commands…

Something like:

M593 X F5
M593 Y F5
M593 F10

That will show the current settings, attempt to set the X option, show the results, set Y option, show results, set both options, show results…

As I said, tried both console and UI and nothing works, setting Y will set X

It looks like the options have changed since I originally added this to the builder… It seems that INPUT_SHAPING has been replaced with INPUT_SHAPING_X and INPUT_SHAPING_Y.

I’ve updated the scripts to build the firmware - if you use the builder, try giving that another go now and see if you get the desired outcome.

Thanks! It is fixed and works great :slight_smile: (I printed a ringing tower with the old firmware and wasn’t sure if I was going crazy because I couldn’t see a difference on the Y axis before I figured out what was going on :smiley: )
Just a side note - my saved profile got deleted for some reason, was it because of the builder update or did something else cause it?

See the pinned thread on this - and the notice on the pages…

In a nutshell, the database files on disk corrupted, including all backups. I recovered as much as I could (which was about 99% of user accounts, and about 50% of printer profiles), but some information was lost.

I’m working on a realtime replica for the database now - as well as daily dumps from both the master and slave databases to try and make sure it doesn’t happen again - and if it does, its easy to recover data…

Ah shit didn’t see that post, that sucks :frowning: good luck with the recovery tho and thanks for all this :slight_smile: