M112 Shutdown every print

Hello there. First post here.
I was using Marlin Ender3-V2-Stock-20220206 firmware and Octoprint 1.7.3 when this happened. It simply stopped to print with this message on the display.

On the Octoprint Dashboard I got this message:
Thermal Malfunction, system stopped! Heater_ID: E0

And I found this option under Octoprint Settings:
Send M112 on disconnect due to errorIf this is checked, OctoPrint will try to send an M112 prior to a disconnect due to a (fatal) error in order to disable heaters and motors.

My question here is:
Is this something about Firmware X Octoprint not doing fine? May I have this M112 option unchecked? Is this some hardware issue?

Any hint, I will appreciate.

Ouch M112 is e-stop.It had a temperature issue, weather the thermocouple quit reading temp or the heater circuit opened. It saw a fault and went into e-stop. M112 is a result of a fault. To somehow turn it off wouldn’t work. Check all the connections on the board. They get loose after several uses of heating and cooling.G Codes and M Codes for 3D printing - What's New In The 3D Printer World-Customize 3D-2022

It looks like there may well be a bug in a new feature in Marlin.

I’ve disabled that feature and am currently building new binaries for testing.

Try updating firmware and give it another go…

Hi, is this corrected in todays build for ender 4.2.7 bltouch? Flashed a bunch of my printers after board upgrades and getting M112 mid print on all of them. Will re flash tonight if new binary is up. Thanks :slight_smile:

In theory, this should be fixed in any versions 20220214 and later.

For anyone facing this issue, here is the solution.
It is related to a new feature to help on fire protection, implemented on the bug releases.

I just complied the last Marlin firmware ( and my printer is back to normal.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.