Newbie confusion about ender 3, which firmware to use

Hi, I am a new subscriber to the marlin firmware service, I have confusion about which version to use for my ender 3.

My printer is a “Ender 3 Pro”, it has the 8-bit board (v1.1.4 I think), and right now is I guess what you call “stock” (no auto bed leveler installed, no creality parts like hot end replaced)

I don’t see Ender 3 Pro in the list of downloads, do I use “Ender 3 Stock” ?

thanks, Scott