Printer LCD unresponsive after flashing

Hi everyone!
I’m on an Ender 3 Pro with an SKR Mini E3 v3.0 controller and OctoPi. I just flashed my printer with the latest firmware on the site. After flashing, the LCD loads slowly,

Marlin loading slowly

Also, the LCD becomes unresponsive and I can’t use the dial to move through the menus. When I reflash with the stock BTT firmware, everything goes back to normal.

Any suggestions to what I’m doing wrong?



If you insert a correctly formatted SD Card into the printer, does the problem go away?

Yes, the format of the card doesn’t seem to be the issue. I can use the same SD card to flash the stock firmware from the BigTree GitHub repo and everything works as it should. It’s when I flash with the firmware from this site, it goes buggy.

I just tried compiling the firmware myself using Bugfix 2.1.x. I had the same problem and asked about it on reddit. Apparently, this is a bug in Marlin 2.1.x, I filed a bug report on github.

[EDIT] Apparently, this is an existing bug:

Thanks for doing this - I know there was initial work done to try and fix.

I’ve imported the PR linked in that - as apparently it works around the issue - until a proper fix can be obtained.

The custom builders have this patch applied now - and I’ll have to re-run the nightly builds again to incorporate it soon.

I tried a custom firmware this morning, but it seems buggy. When auto homing, the axis’s move VERY slowly. With a standard firmware from this site, everything seems to work properly.

I also pulled Marlin from GitHub this morning and compiled it. This build still has the bug, my LCD went slow and I was unable to get into the LCD menus. I reflashed the standard firmware from this site and the problem went away. I dug into the repo, only the “gcode” and 'inc" have been updated, everything else hasn’t been updated for about a week or more.

Since you said that your pulling from the same repo, not sure why my build came out with the bug. I might have to wait until they update again to try rebuilding my own firmware.