Slow auto homing with custom firmware

Hi everyone!

I have an Ender 3 Pro. When I download a precompiled firmware, everything works properly. However, when When I use the custom firmware builder, for some reason, my bed leveling gets really slow. Here is what I’m putting into the custom firmware builder:

Creality → Ender 3 + SKR Mini E3 V3.0

Printer Options → Stock settings

Steppers and Endstops → Stock settings

Bed Leveling →
Bed Leveling Probe → BLTouch
Use Probe port for Probe
Bed Leveling Method → Bilinear Bed Leveling
Grid Size → 5

Leveling Options
Add LCD Leveling menu
Enable Babystepping
Enable Level Bed Corners

Additional Features
Enable Speaker
Filament Runout Sensor
Linear Advance
M78 Print Counter
S Curve Acceleration
SD Card Support

Does anyone have any suggestions as to what I’m doing wrong?