Stock Ender 3 Pro v4.2.2 stock lcd - no display

I have a stock Ender 3 Pro with v4.2.2 motherboard, stock lcd display. With current builds, software appears to load ok, but the lcd display stays blank.

When I self compile Marlin for this printer I understand that that if I select #define CR10_STOCKDISPLAY then an additional #define RET6_12864_LCD has to be added for the display to function.

Could this additional define not being added be the cause of my blank display after loading the latest build??

Thanks for any insight…

Opelika, AL

The code in question is:

  #define RET6_12864_LCD  // Specific to the SoC (can either be RET / VET)

As such, if CR10_STOCKDISPLAY is defined, it will also define RET6_12864_LCD.

Did you use a nightly from my site? If so, which one?

Yes, I have used the nightly for both the Ender 3 PRO v4.2.2 and the Ender 3 MAX v4.2.7. Both result in a blank display.

If I compile myself, both printers, with the above snippet exactly as you have displayed them, then I get the correct display. So I was suspecting that snippet is my problem with the nightly builds.

But it might be something else. Regardless, I am getting blank displays for the stock display for both the Ender 3 PRO mb v4.2.2 and the Ender 3 MAX mb 4.2.7 using the nightly builds.

I am at a loss to explain my problem.

Tnx for reaching out.

Opelika, AL

Just downloaded and installed Ender3-Max-v4.2.7-20220922.bin, no joy, display still blank. If not too much trouble, please include the snipped you referenced #define RET6_12864_LCD. If you will email me that bin I can try it.

I know when I compile myself for my stock displays for both the Ender 3 Pro and Ender 3 Max, the display is blank unless you activate the #define CR10_STOCKDISPLAY and include the #define RET6_12864_LCD.

sf.mitchell (at)
Opelika, AL USA

The base configs come from:

That’s for the v4.2.2 board.

The Ender 3 Max config comes from here:

As you can see, its set in both configs…

As such, maybe this is a bug and not a config error.

Just as a suggestion, have you tried re-formatting your SD Card? Maybe the flash isn’t quite working properly?

I certainly can’t seem to find a problem with the configuration of the build itself…

Took your suggestion and re-formatted the sd card. Fresh card for both Ender 3 Pro and Ender 3 Max. Loaded latest daily complies for each. Nothing different, still blank display.

I can compile myself, and the .bin loads just fine with proper display on both printers.

Hardware Ender 3 Pro: Creality Motherboard v4.2.2
Processor GD32F303RET6 512K
Board marked A/C for drivers

Hardware Ender 3 Max: Creality Motherboard v4.2.7
Processor STM32F303RET6 512K
Board marked A/C for drivers

Bug in Marlin?

Opelika, AL

I’m not exactly sure - I got someone to test the config completely separate to my environment and their display worked fine.

I’m at a loss to understand what could be the issue - as the config is certainly correct.

I’m wondering if the platformio build cache is causing a problem - so I’ve disabled it for the next run of builds today (about an hours time) - and lets see if that makes any difference…

If not, its back to troubleshooting!

Somewhere along the way this was added to the Configuration.h
#define SERIAL_PORT_2 3
But the serial port 3 IO pins are on the LCD connector.
This is a pin conflict.

1 Like

So, following this further - it seems the Ender 3 configs have: //#define SERIAL_PORT_2 -1

The Ender 3 Pro configs have: #define SERIAL_PORT_2 3

As mentioned, this seems to be incorrect.

I’ll set up the builds scripts for the nightlies to disable SERIAL_PORT_2 on all the Ender 3 configs. We’ll see if that works afterwards.

@mitchsfm - Are you able to try todays build and see if this problem is resolved?

I can confirm this is happening to me as well. Screen blank. Is there a specific fix?