Strange retraction behavior on Ender 3 v2


after upgrade to Marlin version 2.1.x (Ender3-V2-BLTouch-20220806.bin) in my Ender 3 v2, retraction is behaving strangely.

I try a lot of things, using pre-build firmware in Marlin Firmware Service (paid version), built a custom firmware disabling Linear Advance, Firmware Retraction and Meatpack, but the bug continue.

I`m using a Cura and not modify any settings after upgrade firmware.

Retraction take a long of time and have duplicated movements and strangely behavior, see video:

My calibration cube g-code, generated by Cura:

My current start g-code:

; Script based on an original created by tjjfvi (

; An up-to-date version of the tjjfvi's original script can be found

; here:

; Note - This script will only work in Cura V4.2 and above!

; --- Global Settings

; layer_height = {layer_height}

; smooth_spiralized_contours = {smooth_spiralized_contours}

; magic_mesh_surface_mode = {magic_mesh_surface_mode}

; machine_extruder_count = {machine_extruder_count}

; --- Single Extruder Settings

; speed_z_hop = {speed_z_hop}

; retraction_amount = {retraction_amount}

; retraction_hop = {retraction_hop}

; retraction_hop_enabled = {retraction_hop_enabled}

; retraction_enable = {retraction_enable}

; retraction_speed = {retraction_speed}

; retraction_retract_speed = {retraction_retract_speed}

; retraction_prime_speed = {retraction_prime_speed}

; speed_travel = {speed_travel}

; Ender 3 Custom Start G-code

M117 Bed up to temp

M140 S{material_bed_temperature_layer_0} ; Set Heat Bed temperature

M190 S{material_bed_temperature_layer_0} ; Wait for Heat Bed temperature

M117 Pre-heating extruder

M104 S{material_print_temperature_layer_0} ; Set Extruder temperature

G28 ; Home all axes

M117 Auto bed-level

G29 0; Auto bed-level (BL-Touch)

G92 E0 ; Reset Extruder

M117 Wating extruder temp

M109 S{material_print_temperature_layer_0} ; Wait for Extruder temperature

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position

M117 Prime hotend started

G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line

G1 X0.4 Y200.0 Z0.3 F5000.0 ; move to side a little

G1 X0.4 Y20 Z0.3 F1500.0 E30 ; draw 2nd line

G92 E0 ; reset extruder

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

M117 Print started

; End of custom start GCode

I haven’t been able to reproduce this, nor seen any other reports of it - but I have a couple of suggestions:

  1. Try to disable linear advance via: M900 K0
  2. Make sure your slicer isn’t set to use hardware retraction

It looks like your retraction is being set to 6mm - which might well be excessive.

A layer height of 0.32mm won’t be doing you much either - as if you only have the stock 0.4mm nozzle, this is really pushing the limits…

I try to use M900 K0 without success.

With firmware-retraction works fine, but I want to use slicer retraction, have more features and is more easy to use.

I try too compile v2.1.1 version with firmware-retraction enable too, put zero in all firmware-retraction codes M208 and M207 and disable firmware-retraction in slicer, but not work.

My firmware codes:

Interesting. I’m not sure if this is you, but there seems to be an issue logged about something possibly similar:

EDIT: Scratch that - I just noticed that you’re the same person - as the google drive links are the same :smiley:

Interestingly, in the G-Code you generated, there are no retractions at all the from the slicer.

It is doing wipes, as such:

G1 X106.1 Y106.1 E13.78001
G1 X118.9 Y106.1 E14.24831
G1 X118.9 Y118.9 E14.71661

I wonder if you could re-slice with the extruder set to relative instead of absolute so it’d be a bit clearer in what its generating?