Unable to compile Ender 3 V2 -

I am using the Firmware Builder but cannot compile firmware if I select “DWIN - Jyers UI” as the display.

Steps to recreate:

  • Select Ender 3 V2 4.2.2 from builder
  • Select DWIN - Jyers UI from the Display Section
  • Build the firmware

Result: Marlin/src/HAL/STM32/…/…/inc/SanityCheck.h:2637:4: error: “Please select only one LCD controller option.”

Build Reference: faae2574

I haven’t had a chance to dig into this yet - but if you select a different UI choice, does it work?

Just trying to give myself more info when I sit down to see what’s going on.

Mixed results. I tried three other configurations with default settings. Only change being the display.

BTW, last time I compiled successfully with Jyers UI was 12/31/2022.

Build Reference: e0bbcfb0
Display: DWIN - Creality Stock

Build Reference: e0bbcfb0
Display: DWIN - Pro UI

Didn’t Work
Build Reference: ec33dede
Display: CR-10 Stock

Marlin/src/HAL/STM32/../../inc/SanityCheck.h:2637:4: error: "Please select only one LCD controller option."

Marlin/src/HAL/STM32/../../inc/../HAL/STM32/inc/SanityCheck.h:84:6: error: "Serial Port 3 TX IO pins conflict with another pin on the board."

I think I’ve fixed this problem now - it was a conflict between the preset and the builder options which was causing two displays to be enabled - when it should only be one.

Can you please give this a go and see if it resolves the problem?

Ran quick test without changing any options other than Display and it worked. Will post back if it breaks in another way. Thank you for fixing!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.