Z-axis below zero

My z-axis wan’t move below zero after upgrading software.
It work’s with my own compiled marlin firmware.

This isn’t a bug - you shouldn’t be able to move the nozzle below zero - otherwise your nozzle will hit the bed.

Perform a G28 / Home and you should be able to move down to Z0.

Thanks for your answer, but I was probably very vague. I upgraded my firmware, and when you do, the zero value disappears so you have to set it again. My zero ended up 11mm above the buildplate after the upgrade!
Therefore you have to go down below zero to create a new zero value … When you then save this new value, it becomes the new zero.

Are you talking about a Z-Offset?

Are you using a BLTouch?

Yes, sometimes you complicate things unnecessarily. Z-offset is exactly what it’s about. Yes, I have bltouch. I think it may have something to do with how you connected your bltouch to the motherboard. When I compile Marlin firmware myself, it works perfectly. But when I use Marlin nightlies firmware none of them works. I have Creality ender pro with a 4.2.7 motherboard. I read here on the forum that there are problems with bineralines advanced and creality printers, maybe this is the problem.

Maybe you should post some pictures of your setup… I have never seen a BLTouch with an 11mm offset. With a value that far out, I can’t even picture what may be wrong…

The normal offset is between 0.7-2.0mm.

In the v4.2.7 boards, the BLTouch should connect to the PROBE port - which is the 5 pin header on the mainboard.

Wrong of me, it was not the z-offset that was the 11mm distance to the buildplate, it was the distance after homing. Z-offset was 1-2mm error after updating. I have been using Bltouch for about 1 year and together with my 4.2.7 motherboard for about 6 months and updated the firmware a number of times without any problems. It all started with nightley firmware. Bltouch can be mounted in three different ways I think. Which works best seems to depend on who you ask. I have my connected to the original Z port I think. It has worked well. I have also tested another way, also worked well. but I have not tried to use the adapters that came with Bltouch because at the time it seemed that many had problems with this. I think I’ll put this aside for now and continue to compile my own firmware and wait a bit with nightley firmware. Thank you for your commitment, it is unbelievable that you can only ask one question and immediately someone wants to help! Thank you!

Betyg: 4,3 · ‎50 röster


i have an ender 3 with 4.2.7 board with bltouch and unable to move z axis below zero, what do i need to do to set z offset? at zero my nozzle is way above bed

What works for me is to first level my bed, then go into the menu to Configuration → Advanced configuration → Set offsets → Z Probe Wizard. The wizard will auto home your print head and then move the nozzle to the center of the bed. Take your piece of paper and slide it under the nozzle and select “Move 1mm”. Once your nozzle is close to the paper, go back one menu and select “Move 0.1mm”, get the nozzle closer, go back one menu and select Move 0.025mm" and fine tune the nozzle further. Once you have the right nozzle distance, go back a menu again and choose “Done”.

Not sure if it’s necessary, but I always go back a few menus until I find “Store Settings” and store the Z probe.

1 Like

Thanks Zogthegreat! I was having the same issues with my BLTouch 3.1 (5pin) and Ender 3 Pro (4.2.2). This helped squash my issues. It’s just a little different way of thinking from the stock firmware.