Z Probe Past Bed Error During Bed Tramming

Hi All,

Been going crazy here trying to figure this out.

Upgraded my Ender 3 v2 with BLTouch and a 4.2.7 board to Marlin firmware build 20221125. I wanted to upgrade it finally to get Linear Advance. Went from 20211121.

After entering in all my values for steps, acceleration, and probe offsets, I can build a 5x5 mesh properly. But when I try to use the Bed Tramming, I can only get the Front Left and Rear Left sides to measure. When I try to get the Right sides, I get an error message of “Z Probe Past Bed”.

I’ve checked my probe offsets, and measured them again. I currently have:

Probe X Offset: -43.1
Probe Y Offset: -7.0
Probe Z Offset: -2.48

The Info Screen on the printer shows the following:

Size: 225x225x250
Firmware version: bugfix-2.1.x
Build Datetime: 2022-11-25

I’ve tried a build from three days ago, yesterday, and today, and all produce the same error.

If I roll back to my much older version, 20211121, the issue does go away, but this is missing the new Linear Advance Feature I’m using, and a lot of other fixes since then.

Am I missing something?

While I don’t know the exact problem off-hand, -2.48 is a huge Z-offset.

I can’t remember exactly what the movable length of the BLTouch probe is - but I think the max is ~3mm.

I’d try to reduce that to about -1.5mm via adjusting the hardware and see what you can get.