Ender 3 Max 4.2.2 with BLTouch, Extruder will not Autohome

Dear lovely person who builds the things,

Because I am a moron, I installed Creality’s Direct Drive kit on my Ender 3 Max. All is well in theory, except the BL Touch … well, bad things. I am sad.

So first the problem was that the BL Touch mounts on the left side of the Direct Drive kit, but right side of stock extruder. That went badly because the probe ended up in space (luckily I live with one hand on the power switch).

The Google said I need to do offsets, cool, I got those, but the firmware I was using didn’t have offset options, and then Google said come here. Hello.

So I done your firmware. It is very lovely and has many exciting menus that weren’t there before.

But what’s happening is this. System starts up fine. When I Autohome, the probe extends and retracts a few times, and then the system stops. As in, crashes. Infoscreen with the word STOPPED.

I have been doing my nut trying to figure this out, because it worked with the old setup; nothing has changed. Buuuuuut then I remembered that I had had to hack a cable to make BLTouch work; you have to remove the stock Z-endstop, and put the cables from the BLTouch instead.

Figuring the cable was the issue, I ordered more cables. Same problem.

I’ve made two different cables; one default tiny to big 5-pin, and one with the Z-stop pulled out to a separate plug. Neither works. I want to cry.

I know it’s not your problem to troubleshoot my hardware issues … but it was working. And then it wasn’t.

Do you possibly have any suggestions for me? The sorrow is vast.

Thank you.


Some additional information, for what it’s worth.

I have isolated the problem further: using your BL-Touch firmware, the Z-axis will not lower. I removed the BL Touch and reverted to stock Z-axis sensor. Problem persists: z-axis will not lower.

Flashed your latest firmware WITHOUT BL-Touch, and now the Z-axis works again.

So this very much does not look like a hardware issue.

Any assistance would be greatly appreciated.

Sorry I haven’t replied - I’ve been busy migrating as many systems as I can from RedHat to Debian after the latest braindead moves. It’s taking a bit longer than anticipated :slight_smile:

The nightly builds expect that the BLTouch is connected to the 5 pin socket on the mainboard.

A key giveaway that the wiring is wrong is if the probe does multiple deploy / stow cycles. There is a general BLTouch FAQ that hopefully helps with the most common problems.

As for Z movement, most of my builds will not allow a negative Z movement until the printer is homed. This is a protection mechanism to try and prevent people from accidentally driving their nozzle into the bed (as we’ve all done).

You should be able to move down to Z=0 after homing the printer.

Well, sorry I haven’t replied. I work in agriculture, my days are crazy.

First, I want to say thank you for the heads up about needing to home the printer, that was super helpful.

The rest of the stuff I was moaning about actually had nothing to do with the firmware in the end, especially not after I homed it like you suggested. I imagine your project, while it improves life on the planet, probably mostly results in you getting moaned at a lot by people like me.

Absent the homing (which is sensible as hell in retrospect), my issues were in fact all hardware related, and mostly to do with cable runs, and protection thereof. I guess it might have helped if I’d known about your compile assumptions, but not really. Would’ve saved 10 mins out of 6 weeks of messing about.

I am pretty sure at this point that Creality does not sell printers so much as education courses in how to build a printer. Most Creality owners (myself included) miss the part of the manual where it says, this is a framework, replace everything, assemble it properly, and it’ll be a good printer.

This is my conclusion, since I feel I could probably build a printer of this type from scratch now.

Anyway, yes, the buggers were mostly in the cabling, and it all works now, so, just giving you feedback since you so kindly replied. Thank you for the work you do. You’re the hero we need, but do not deserve.

Have an excellent weekend, month, year, and life, you lovely person.

Thanks for the kind feedback.

3D printing is both a blessing and a curse. No matter what printer makers tell you, its still complex with a million gotchas and weird moments. It’s still nowhere near plug’n’play.

It’s also an industry of moving parts (heh) - and any one of them could be at fault - so we end up debugging based on educated guesses and pain :laughing:

Glad you got things worked out though - its a good achievement when it works as it should :slight_smile: