Ender 3 v2 BLTouch - Doesn't Work

NOTE: Tried to add pictures directly in this post, but it will only allow me one. I have added the referred to pictures on this share: Link to Share with Pictures

I have an Ender 3 v2 with a 4.2.2 board.

I have been able to flash this firmware:
Ender3-V2-BLTouch-20220205.bin from
https://marlin.crc.id.au/firmware/Ender%203%20V2%20-%20BLTouch/
and I fixed the display with DSET files.

I am following the wiring as shown on the link above, using the BLTouch port on the board (see picture above with board version). (NOTE: I have seen other sites using part of that port and the z-port for the black and white. That requires other build switches, but this site shows using all the pins on the BLTouch port on the board which I am doing. I have checked about 5 times to verify all pins are wired correctly. I have an original BLTouch (v 3.1) and the wire colors are even the same. See board version picture above this BLTouch end:
PICTURE

I have the z-switch disconnected at the switch.

When I turn on the printer, the BLTouch goes through 2x down/up routine while red (with a blue dot) and then stays in the configuration with probe up.
PICTURE

If I select on the screen to have it “auto home”, it will move up (z) about 10 mm, then home to the limit switches on the x and y and move to the center. But then it moves up 10 mm and goes through an down/up routine again (red glow with blue dot) and then switch to blue glow with a blue dot (or maybe glow from blue dot led) and probe down. Sometimes it will then repeat this (minus the move up to start) and then just sit at the blue dot, probe down and do nothing. IT NEVER MOVES DOWN. NOTHING NOTED ON SCREEN, BACK TO MENU.
PICTURE

If I choose to “Level” from the main menu, it does something similar but on the screen it says “Home Z First”.
PICTURE

I tried that first.

I have also tried to “load defaults” “save configuration” (says it save it). Turned off printer, back on, and tried all of this again with same results.

I don’t know what to try next. HELP!

After trying many other things, if I go to the probe wizard and try an autohome, I get error messages about Warning: Z position unknown.

Under the advanced menu, view mesh says their is no mesh. Endstop diag says x and y are open and z and filament are triggered.

Have you run through the BLTouch FAQ?

This covers most issues.

Like 5x… both the Ender 3 v2 FAQ and the BLTouch FAQ.

So if it deploys for the self-test on power on, but not when told to deploy from the menu / g-code, then the 3 signal wires are incorrect.

Make sure if you didn’t buy the thing from Creality that the wiring is correct - as there are a couple of swapped pins in the cable from the stock AntLabs one. This can cause all sorts of problems with the mainboard, and even kill it.

My mistake, I don’t think I was clear. The probe deploys and turns blue. It is down. I have a pict linked in my original post.

The entire print head / gantry won’t go down. It never moves down to probe the bed, even if I move the z-offset to -10 mm, won’t move. It only goes up with the BLTouch installed. It will move up 10 mm if I try to home. I can do the home multiple times and it goes up. But, if I switch the FW back to non-BLTouch FW and reconnect the z-endstop switch, it will go up and down, home fine including the Z using all 3 switches.

Does it allow you to move to Z0 after performing a home?

How do I have it move to Z0?

Please see the video I just posted in the original file share link (BLTouch Issues – Google Drive) of what is does and a few diag. steps and results. Maybe that will help.