Ender 3 V2 Stock Display Icons Missing after Firmware Upgrade

I have an Ender 3 V2 with a 4.2.7 motherboard and BLtouch. With a properly formatted 8GB SD card, I have tried using the 20210912.bin, 20210918.bin, and the 20210917.bin from the archive along with the new Dwin_set folder from the archive but the screen is still glitched out an refusing to load icons.

Edit: After formatting the SD card through Command Prompt like Piranja says it finally updated correctly rather than updating through the file explorer.

1 Like

Finally got back to this and the SD Card format was the issue for me. MacOS won’t work no matter the format tool. As mentioned, follow the detailed steps above on a Win10 machine and it will work.

After tadays flash (21/09/2021) i got similar error saying: “EEPROM Version Error” and had to restore my eeprom from backup and do mesh bed leveling again. Is this going to happen every time I flash new firmware now? Annoying…

This will occur when the storage structure of the saved EEPROM data changes.

Set up again, save your settings and you won’t see it again until the next EEPROM data format change.

Thank you for clarification. :slight_smile:

I have the same problem after firmware flash, I have tried formatting the SD card in every way windows 10 and 11 and also the SD card formatter, the screen goes blue for maybe half a second and then it turns orange, but nothing.
I was wondering if any one has come across a solid solution for this? as this very annoying to have to guess what function you have chosen if you have to scroll back since all of the squares where the icons used to be stay lit/ highlighted when you scroll up.

I flashed the firmware for the ender 3 v2 with bl touch 4.2.7 board and now there are no icons and when scrolling to the next option the last blank square where the icon used to be stays lit… ( if you scrolled from the print icon to the level icon, all four little square will be highlighted ) on the control screen.
I have tried formatting the SD card every which way, the board goes blue for half a second and the orange, but still it does not work.
has anyone found a solution for this, it is really annoying to have to guess which function yo have chose when trying to scroll back.

Mines been like that for months. I’ve gotten used to it. I tried upgrading the display firmware and that didn’t help in that sense. It’s been a good 9 months. I’m starting to wonder how much work is actually done on these “Daily Builds”.

I’ve updated the DWIN_SET.zip file for the Ender 3 V2 - it looks like it was changed ~8 days ago and my scripts didn’t notice to repack it.

Try again with the latest DWIN_SET.zip and let me know if it fixes the issue.

(It’ll take about 30 minutes to propagate to the web site. It should be dated 27th Jan when it comes through)

I’ve just joined so welcome everybody.

I had been struggling with upgrading my Ender 3 v2 to newestMarlin for a while (card preparation, and firmwares) but in my case it seems that I:

  1. tried to upgrade display without having newest firmware in place. Basically , my tries to upgrade firmware didnt work when I had display folder and other files on sd card - so icons were reduced to barely readable text
  2. maybe it is not the case but tried with firmware bin and display folder present on the same card.

So , I’d updated screen (blue → orange) but there was no good results - icon problem
Prepared firmware using builder and left it on sd card as the only file.
Standard upgrade procedure and voila screen also started working properly.Versoin shown is bugfix.2.0

So, I think:

  1. proper card preparation
  2. firmware first as one file on the card
  3. display folder upgrade also as only one present on the card

I tried the updated DWIN_SET and NO GO.
flashed firmware from 1/27/2022 and same thing.

i tried this also and did not work for me, i though I had received a bad main board so I bought a second one and the same problem.
no icons.
:face_with_symbols_over_mouth: :face_with_symbols_over_mouth:

I just reflashed Ender3-V2-BLTouch-20220129.bin and the DWIN_SET.zip to my Ender 3 V2 and both are accepted just fine and have icons as expected…

Just to make sure, are you flashing the DWIN_SET folder via the uSD slot on the back of the screen itself? You need to pull the back off the screen to get access to the uSD slot…

Creality video here:

I did this with the CREALITY official firmware and it works, but when I flash the marlin firmware from this site all of my icons disappear ( I don’t know what the deal is)
on the other hand I downloaded the marlin firmware from the GITHUB website JYERS and then clicked on the little green and white button (latest version) downloaded the newest they had there I this it was from November 2021 and that worked, the only thing I noticed is that my printer now prints a little slower that it did with the firmware from this site.
other than that everything works and now I have ICONS.
it might be a bug in the firmware from this site.
I don’t know.

link to the firmware that worked for me is listed below I hope this helps someone with the same problem I was having as it is really frustrating your stuff jus does not work right.

Make sure you are using the correct DWIN_SET for each firmware version. The firmware loaded to the screen is different.

I used the latest release and DWIN_SET files for ender 3v2 with BL TOUCH from the list on the website but as soon as I flash the firmware, the icons are gone( only text in the squares) and all squares stay lit when scrolling, so if I wanted to go back one square I would know what i am clicking on until the function I clicket opened.
I tried numerous time to flash the DWIN_SET to the display and it will not take it.
this is weird.

This is more than likely a problem with the way the SD Card is prepared. Make sure you’re using a low capacity SD Card (8Gb or lower) and prepare it according to the instructions on this thread. Flashing the screen is a lot more picky about the SD Card format than the mainboard.

I tried all the steps listed in the thread but I can’t get it to update firmware. I upgraded to Touch Screen before I tried to update my screen firmware could that be the issue? Is it detecting a newer firmware than the one I’m trying to install? Could it be because my Mobo is 4.2.2 and I used the firmware builder from this site.

I formatted as 2GB and I used FAT32GB using the same SD card creality provided which is 8GB.

The Creality touch screen is not supported. Only the stock Ender 3 V2 screen.

Could u link me a screen firmware for non touch screen? The stock screen also doesnt work for me using the latest DWIN from marlin configs.