FIlament Runout Sensor on Ender 3 Max (4.2.2 + BLTouch) nightly firmware

Hi there! I have exactly the same problem as ecard, namely that the filament runout sensor is reversed (it detects filament when there isnt one inserted). Is there a fix for this or could you change the nightly version accordingly?

The firmware builder does not work for me, because the CR-Touch just does not stop when bed levelling and digs into the bed without stopping until the firmware fails.

Still have that issue and don’t know how to fix it. Could you help me with that please?

If you’re using the nightlies, then it ONLY supports the rotary encoder types of filament sensors.

If you use something different, you’ll have to configure it for yourself via the Firmware Builder.

If your probe doesn’t detect the bed and stop, then you have the wrong options selected for where you have your probe connected. ie Z-Stop vs Probe port etc.