Firmware link downloads HTML file

Im trying to download the firmware but it just downloads a webpage

This is likely your browser messing up.

The file you download is either a .bin or .hex file. If you rename it to that, you should be good to go unless your browser is really broken.

Im getting this too where I was previously able to download the bin file ok and Ive changed nothing. The file is too small to be the firmware its only like 10K and contains html.

If I copy the download link and past into address bar the page is redirected to the firmware page:

Redirects to:

Im definitely signed in too.

I signed in and then tried your link - it worked for me?

The file I get is 183,148 bytes.

LOL, I dont know then?

All I know is it worked the last time I downloaded which was “Ender3-v4.2.7-BLTouch-20220319.bin”

I just tried Edge and that worked. Must be something Chrome related

I use Brave as a browser - its based on Chrome - but with adblocker and anti-tracking baked in. I can’t really comment on other browsers…

At least its free and easy to change browsers these days :slight_smile:

I have the same problem. have tried MS Edge and Firefox and same result for both.

I can confirm same thing on Firefox, Edge and Android Browser today.
EDIT: Ender 3v2 BLTouch, 4.2.2

If someone wants to send me the HTML file that their PC downloads so I can take a look…

Fire it to and I’ll see what I can see.

Please don’t post it here - as if it isn’t the binary file, it may contain your personal information.

File sent.

Thanks for the file - really strange.

I’ve made a couple of changes based on educated guesses… Can you try again and see if you see proper behaviour now?

Still the same.

EDIT: I think I found something;

Link that do NOT work:

Link that DO work:

Just “/” (slash) before file name “Ender3-V2-BLTouch-MarlinUI-20220526.bin” and it works.

Yes, there should always be a slash in between the firmware filename and the path…

The above is the link I get from right-clicking the Download Icon - which seems correct.

EDIT: Ohhhhh wait - I see what you mean… It seems if there isn’t a trailing slash on the path when you visit a file listing for a printer, the download links break too… This shouldn’t happen internally - but I guess that could break it if someone links externally from outside of the site to a link internally…

Let me take a looksee and fix that up…

Ok, give that a go now and see if you still have the same issue…

WORKS! Thank You.

1 Like